Update Node.js to v20
continuous-integration/drone/pr Build is passing Details
continuous-integration/drone/push Build is passing Details

This commit is contained in:
Kasper Juul Hermansen 2023-04-20 21:19:01 +00:00
parent 409ac8122d
commit 71bd74833b
1 changed files with 3 additions and 3 deletions

View File

@ -1,5 +1,5 @@
# 1. Install dependencies only when needed
FROM node:19-alpine AS deps
FROM node:20-alpine AS deps
# Check https://github.com/nodejs/docker-node/tree/b4117f9333da4138b03a546ec926ef50a31506c3#nodealpine to understand why libc6-compat might be needed.
RUN apk add --no-cache libc6-compat
@ -8,7 +8,7 @@ COPY package.json yarn.lock ./
RUN yarn install --frozen-lockfile
# 2. Rebuild the source code only when needed
FROM node:19-alpine AS builder
FROM node:20-alpine AS builder
WORKDIR /app
COPY --from=deps /app/node_modules ./node_modules
COPY . .
@ -16,7 +16,7 @@ COPY . .
RUN yarn build
# 3. Production image, copy all the files and run next
FROM node:19-alpine AS runner
FROM node:20-alpine AS runner
WORKDIR /app
ENV NODE_ENV=production